Advertisement




Edit Report

Our sensors found this exploit at: https://cxsecurity.com/ascii/WLB-2022030063

Below is a copy:

Automatic Question Paper Generator System 1.0 - Cross-site scripting stored
# Exploit Title: Automatic Question Paper Generator System 1.0 - Cross-site scripting stored
# Date: 2022-11-03
# Exploit Author: Mr Empy
# Software Link: https://www.sourcecodester.com/php/15190/automatic-question-paper-generator-system-phpoop-free-source-code.html
# Version: 1.0
# Tested on: Linux

Title:
================
Automatic Question Paper Generator System 1.0 - Cross-site scripting stored


Summary:
================
The Automatic Question Paper Generator in version 1.0 is vulnerable to arbitrary persistent javascript code injection (XSS), which can lead to thwarting of browser resources and session cookie theft.


Severity Level:
================
7.5 (High)
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N


Affected Product:
================
Automatic Question Paper Generator v1.0


Steps to Reproduce:
================

1. Open your browser, create an account on the site and log into it (http://target.com/aqpg/users/login.php).

2. Click on your profile icon and then click on My Account. The field called "First Name", "Middle Name", "Last Name" are vulnerable to XSS, inject the payload into one of them and then save your changes.

Copyright ©2022 Exploitalert.

All trademarks used are properties of their respective owners. By visiting this website you agree to Terms of Use.